Subscribe to DSC Newsletter

Getting an Error in RStudio, while loading 'tm' Package

Hello,

I have successfully installed the 'tm' package, which is located in: C:\Users\google\Documents\R\win-library\3.0



Am getting an error in R studio, when I try to load the package 'tm'. 'tm'- Text Mining Package is in--
library ‘C:/Program Files/R/R-3.3.0/library’:

Error:

Error in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]) :
there is no package called ‘slam’
In addition: Warning message:
package ‘tm’ was built under R version 3.3.1
Error: package or namespace load failed for ‘tm’

Any thoughts on this?

Views: 1925

Attachments:

Reply to This

Replies to This Discussion

tm package imports slam (dependancy).It seems that slam wasn't got installed with tm, thats most likely because you've R-3.3.0 and slam requires R-3.3.1. Try installing tm with dependancies = T. Or install older version of slam from source, using slam archive.

Reply to Discussion

RSS

Follow Us

Videos

  • Add Videos
  • View All

Resources

© 2018   Data Science Central™   Powered by

Badges  |  Report an Issue  |  Privacy Policy  |  Terms of Service